Adam Owners Club banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all - my daughter has a 2015 Adam 1.2 with 34k miles done. It's been serviced and looked after but for the last 6 months there is a mis-fire at low revs. The interesting part is that this will come and go. It disappears for weeks at a time and then returns for a couple of days. It finally happened over Xmas while she was visiting us so I got to see it first-hand. The engine code is P0300 and this is the only code visible (I know it's a bit of a general code). I've done plenty of searching and watched lots of videos but nobody seems to have a mis-firing issue that disappears for weeks and then returns.

Any thoughts? Tomorrow, I'm going to look at the engine mounts, check the battery and look at spraying carb cleaner around the inlets, but what is killing me is how it can disappear for weeks. It doesn't always trigger a code or the engine warning light. I cant see it being a fuel filter/pump issue as the issue is not constant. As my daughter says 'the car runs fine more often than it is lumpy'.

Any thoughts?

Cheers

M
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
I solved this one by replacing all the spark plugs (£16) and ignition coil pack (Starline Ignition Coil from Euro CarParts @ £71). The mis-firing could go away for weeks at a time, and i think was down to the weather - it was worse when it was damp. I also found a video on Youtube titled "🇬🇧Corsa Coil Pack Replacement (engine Misfire, Jerking)" - the car had just started the ticking noise mentioned in the video. I took everything apart, and where the coil connected to the spark plugs was in shocking condition - one of connections more or less crumbled as I removed it and some of teh rubber had disintegrated. This was a lot worse than i expected for a 7-year old car.
Anyhow, hopefully this will help others with similar issues.
 
1 - 2 of 2 Posts
Top