Adam Owners Club banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone!

I’m hoping someone can help me please I’m having a nightmare.

My car suddenly cut out whilst driving 30mph last week with no warning and wouldn’t come back on. I finally got it going after about 5 mins and got back home. The next morning I tried to get to work in it before I could get it to a garage and it happened again.

I noticed my Revs were particularly low when driving which was odd. The garage and RAC both couldn’t find any codes and after I left it in the garage for a day they sent me on my way.

I started to drive home and it happened again! So I pulled into another garage that was close by after getting it going again and asked them to have a look. Again no codes - but I left it there because I’m actually scared to drive it.

It’s been there for over a week now with no avail. He drove it himself (he defo thought I was lying!) and it broke down on him too and again NO CODES!

I’m at a loss at the minute without it and also worried to drive it without a fix. The garage don’t seem to be helping as I think they’re putting me off but I need something to be fixed as I have 0 faith in my Adam now.

It’s 5 years old and recently had the evac valve replaced in December (which made it drive like a dream) spark plugs and coil pack have recently been replaced in the last 6 months and no issues from that.

Can anyone please advise on what to do? I’m lost without it and without codes mechanics are reluctant to do anything 😢
 
1 - 1 of 1 Posts
Top